Acess Denied messaage when saving column permissions

May 17, 2013 at 9:42 PM

We have the app installed and I'm trying to test the Column Permission feature by doing the following:

1) Select Column Permission link in List Settings
2) Select a column to edit
3) Add a user to the Edit Form Read Only section to give that user read only permissions

After pressing Save, I receive an Access Denied message. I clearly have access to the app. Otherwise, I would not be ablet to select columns and add users/groups. Why am I receiving the Access Denied message on the Save? I have tried adding different users but receive the same error.

May 19, 2013 at 1:53 PM
Edited May 19, 2013 at 1:54 PM
May 29, 2013 at 9:32 PM

We discovered that the component works in our environment when run by a user who is both a Site Collection Administrator and Farm Administrator. The Access Denied message, therefore, is clearly related to insufficient permissions. What are the minimum permissions/requirements for a user to be able to use the component? Just Site Collection Admin or Farm Admin as well?

May 29, 2013 at 9:46 PM
Hello. I am sorry but settings page is setup for users which have permission to edit or to manage LISTs. Thank you
May 30, 2013 at 6:54 PM
The user that receives the access denied message while saving settings does have both edit and manage list permissions. Do you have any thoughts on what would be causing this error?

Thank you.
Apr 4, 2014 at 3:34 PM
Our users are also receiving the same access denied error when attempting to save the settings. They have full control a the site level with no broken inheritance. As Site Collection Administrator and Farm Administrator it works fine for me.